Compiling latest gpc on latest cygwin

Prof. A Olowofoyeku (The African Chief) african_chief at bigfoot.com
Wed May 16 11:12:56 CEST 2001


On 15 May 2001, at 16:39, Matthias Braun wrote:

> Hello,
> I've got problems with compiling gpc snapshot from 12.5 and latest cygwin
> with gcc 2.95.3-4 I did like described in the faq, and I had some problems
> I solved:
>  -There was no patch for gcc 2.95.3-4 so I took the one for 2.95.3
>  -GPLUSPLUS_INCLUDE_DIR and TOOL_INCDLUDE_DIR wasn't declared in
> gpcpp.c, I found an #undeclare in cygwin.h and deletet it.

I am not sure that you should do that. I think you should trust that 
whoever undeclared it knew what they were doing. I normally can compile 
GPC for both Cygwin and Mingw without touching anything other than to 
apply the GPC patch.

> After that compiling worked, but if I use the compile now, the following
>  appears: (gpc -v test.pas)

Do you have all the latest GNU tools and headers and libraries? You 
shouldn't have had to change cygwin.h to be able to build GPC 
successfully.

[...]
> GNU Pascal version 2.95.3-4 (cygwin special) (i586-pc-cygwin32) compiled
> by GNU C version 2.95.3-3 (cygwin special). GNU Pascal version is actually
> 20010512, based on gcc-2.95.3-4 (cygwin special)
>  as -o /PlatteC/WINDOWS/TEMP/ccc85291 /PlatteC/WINDOWS/TEMP/ccb85291
> gpc.exe: Internal compiler error in `do_spec_1', at p/gpc.c:4500

I have never seen this problem before. The GPC that you built is 
obviously broken. Why? I have no idea. Could it be a problem with your 
"specs" file? Perhaps Peter or Frank might have an idea what this error 
means.

Best regards, The Chief
---------
Prof. Abimbola Olowofoyeku (The African Chief)
Author of Chief's Installer Pro for Win32
Email: African_Chief at bigfoot.com
http://www.bigfoot.com/~african_chief/




More information about the Gpc mailing list