running gpc on Mac OS X 10.7.4

Thomas Schneider schneidt at mail.nih.gov
Thu Sep 6 01:27:46 CEST 2012


Kevan:

> I'm running GPC just fine on 10.7.4. I may have installed on an earlier 
> version of 10.7 and then upgraded. I installed the Mac OS X 10.6 Intel 
> version I found here:
> 
> http://www.microbizz.nl/gpc.html
> 
> What did you install?

I hadn't installed, but I went to that page and installed from
 • GNU Pascal 3.4.6u4 installer for Mac OS X 10.6 Intel native and PowerPC cross-compiler15.7 MB)

It SAYS it's supposed to be ONLY for 10.6, but I went ahead anyway on 10.7.

In /Developer/Pascal it installed cleanly and replaced directory
gpc346u2 with gpc346u4.

I can now compile:

egg 18% cat h.p
program helloworld (output);
begin
writeln(output,'hello world');
end.
egg 19% gpc h.p
ld: warning: -macosx_version_min not specified, assuming 10.7
ld: warning: PIE disabled. Absolute addressing (perhaps -mdynamic-no-pic) not allowed in code signed PIE, but used in __start from /Developer/SDKs/MacOSX10.5.sdk//usr/lib/crt1.o. To fix this warning, don't compile with -mdynamic-no-pic or link with -Wl,-no_pie
egg 20% a.out
hello world

Thanks,

Tom

  Thomas D. Schneider, Ph.D.
  Senior Investigator
  National Institutes of Health
  National Cancer Institute
  Frederick National Laboratory for Cancer Research
  Gene Regulation and Chromosome Biology Laboratory
  Molecular Information Theory Group
  Frederick, Maryland  21702-1201
  http://alum.mit.edu/www/toms



More information about the Gpc mailing list