2nd attemtpt -- gpc and emx09b ?

sad at utkux.utcc.utk.edu sad at utkux.utcc.utk.edu
Sun Mar 17 02:34:55 CET 1996


Sorry if this shows up twice but something bounced, so I try it again.
Stefan


Hi all, hi Peter,

 I was wondering whether it is just me or a known (and maybe even fixed?)
problem:
I just finished installing emx09b on my machine to be able to run things like
the latest gnuplot beta  and all that stuff that gave me warnings about
having to use emx09b. So, all seemed well.
In fact, even g77 worked, it still does after I have installed the version
that had been recompiled with emx09b.

GPC doesn't like me anymore, though. It compiles, but linking doesn't seem to
work, I get stuff like:

rts-file.c:221 (e:/bin/emx/lib/gpc.a(rts-file.o)): Undefined symbol _write
refer enced from text segment

and lots of it. I then fetched a later version from
ftp.uni-augsburg.de since I can't seem to get through to kampi.hut.fi
tonight, and installed it: Still the same problem. I understand that
emxgpc was compiled (or patched) for 2.6.3, but I was wondering whether
there is any hope on the horizon for a transparent gpc under emx?

Interesting enough, gpc --version     reports %PROG2%,
so this may serve as version indication:
rwxa--   161799 Dec 13 00:39 e:/bin/emx/bin/gpc.exe*

but more interesting (and temporary relief!) is, that
gpc -c test.pas
gcc test.o -lgpc

does produce a working executable. Any ideas, pointers, promises are
most welcome!   Cheers!   Stefan




More information about the Gpc mailing list