Pascal on UnixWare 7

Theo Carr-Brion Theo.CarrBrion at
Wed Aug 29 15:20:58 CEST 2001

We tried compiling gpc earlier this year but have been too busy for a while.
This was the outcome:

Problems compiling gpc 20010121 under Unixware 7.1.1 using gcc 2.92.2 and
Skunkware 7.1.1B

1.	rts wont compile 

/usr/local/src/gcc-2.95.2/gcc/p/rts/string.pas: In function `Memcompcase':
/usr/local/src/gcc-2.95.2/gcc/p/rts/string.pas:226: Internal compiler error
in `add_bound_info', at gcc2.95.2//gcc/dwarf2out.c:7376

solved by compiling with -g0. We can live without debugging.

2.	Tried a simple program:	

Program Test;


gpc test.pas gave:

UX:as: WARNING: /var/tmp/cc00027c.s:76:name already bound as global:
UX:as: WARNING: /var/tmp/cc00027c.s:77:name already bound as global:
Undefined                       first referenced
 symbol                             in file
UX:ld: ERROR: a.out: fatal error: Symbol referencing errors. No output
written to a.out

test.s shows init_pascal_main_program etc all repeated.

Theo Carr-Brion

More information about the Gpc mailing list