Missing crt1

Kevan Hashemi hashemi at brandeis.edu
Thu Sep 15 14:19:01 CEST 2011


Dear Adriaan,

Thank you for your help.

> The PATH environment variable is not what the linker is using.

Of course you are right. I was not thinking clearly.

> Apart 
> from linking in crt1.0 manulally

This does not work because there are other libraries missing in addition.

> 1. Check UNIX Tools in the Xcode installer when installing Xcode. This 
> is the simplest solution.

I un-installed Xcode2.5 and re-installed, but did not see any UNIX Tools 
box.

> 2. Add the command line option 
> -Wl,-syslibroot,/Xcode2.5/SDKs/MacOSX10.4u.sdk.

This works. And it's the same line I add to make shared libraries out of 
my Pascal code. Thank you very much.

Last night I tried to solve my problem by running cctools-576 from your 
website. After that, my linker does not recognise the 
-mmacosx-version-min=10.4 option, despite removing and re-installing 
XCode 2.5. Where does this cctools come from? I Googled it, but am 
finding unrelated tools of the same name.

In theory, can I run cctools-576 then run gpc, and so avoid installing 
XCode all-together?

Yours, Kevan

-- 
Kevan Hashemi, Electrical Engineer
Physics Department, Brandeis University
http://alignment.hep.brandeis.edu/



More information about the Gpc mailing list