Re-Install on OSX10.7

Kevan Hashemi hashemi at brandeis.edu
Mon Oct 28 19:10:52 CET 2013


Dear GPC,

I am updating my installation instructions for GPC on all platforms. I 
just uninstalled all XCode files from my MacOS 10.7.5 system with:

sudo /Developer/Library/uninstall-devtools -mode=all

I re-started the OS. I have an installation of gpc, but I could not find 
an uninstall script for the files in /usr/bin, so I just downloaded 
Adriaan's "GNU Pascal 3.4.6u4 installer for Mac OS X 10.6 Intel native 
and PowerPC cross-compiler" and installed again. That package says "for 
MacOS 10.6 only" but I went ahead anyway.

I have the following program:

program p; begin writeln('Hello World'); end.

And I try to compile with 'gpc', but I get this error:

Kevan-Laptop:Build kevan$ gpc p.pas
as: assembler (/usr/bin/../libexec/gcc/darwin/i386/as or 
/usr/bin/../local/libexec/gcc/darwin/i386/as)
   for architecture i386 not installed
Installed assemblers are:
/usr/bin/../libexec/gcc/darwin/ppc64/as for architecture ppc64
/usr/bin/../libexec/gcc/darwin/x86_64/as for architecture x86_64
/usr/bin/../local/libexec/gcc/darwin/m68k/as for architecture m68k
/usr/bin/../local/libexec/gcc/darwin/hppa/as for architecture hppa
/usr/bin/../local/libexec/gcc/darwin/sparc/as for architecture sparc
/usr/bin/../local/libexec/gcc/darwin/m88k/as for architecture m88k
/usr/bin/../local/libexec/gcc/darwin/i860/as for architecture i860

I always imagined that the assemblers were installed with the GCC that 
comes included with GPC, but I appear to be mistaken, because

Kevan-Laptop:Pascal kevan$ find /Developer/Pascal/ -name as

comes up with nothing. Meanwhile I do have:

Kevan-Laptop:Pascal kevan$ find /usr -name as
/usr/bin/as
/usr/libexec/as
/usr/libexec/gcc/darwin/ppc64/as
/usr/libexec/gcc/darwin/x86_64/as
/usr/local/libexec/gcc/darwin/hppa/as
/usr/local/libexec/gcc/darwin/i860/as
/usr/local/libexec/gcc/darwin/m68k/as
/usr/local/libexec/gcc/darwin/m88k/as
/usr/local/libexec/gcc/darwin/sparc/as

In Adriaan's Readme.rtf file, it says, "The following utilities are 
installed with Xcode... as Apple/gnu assembler."

I conclude that I must install XCode in order to compile with GPC. Which 
version of XCode should I install? Starting with XCode 4.0, PPC 
processors and OS 10.4 SDKs are not provided, although it will do 32-bit 
i386. I tried XCode 3.2 but it crashes on OS 10.7. The one that works 
for me is XCode 2.5, just using the command-line tools and SDKs.

Is anyone else using GPC on MacOS 10.7 or later, and if so, are you able 
to use the PPC cross-compiler?

Yours, Kevan

-- 
Kevan Hashemi, Electrical Engineer
Physics Department, Brandeis University
http://alignment.hep.brandeis.edu/



More information about the Gpc mailing list